Jump to content
  • 0

[Problema] 'Mute" Server


Nokian73

Question

Am o problema la server, aceasta este in felul urmator:

Intru pe server cu un cont neinregistrat, ma inregistrez, si nu-mi da voie sa vorbesc pe chat decat daca folosesc comenziile " /local | /say "

Daca dau relog, imi da voie sa vorbesc pe chat normal din tasta " T "

Imi puteti spune de la ce poate fi?  :undecided:

P.S: MOD RPG (nu ma redirectionati la Probleme Godfather va rog mult...raspundeti-mi aici)

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

Am specificat ca, daca dau relog imi da voie sa vorbesc normal !

Comenziile sunt:

	if(strcmp(cmd, "/local", true) == 0 || strcmp(cmd, "/l", true) == 0 || strcmp(cmd, "/say", true) == 0)
	{
	    if(IsPlayerConnected(playerid))
	    {
	        if(gPlayerLogged[playerid] == 0)
	        {
	            SendClientMessage(playerid, COLOR_GREY, "[UltraGaming RPG]: Trebuie sa fi logat pentru a utiliza aceasta comanda.");
	            return 1;
	        }
			GetPlayerName(playerid, sendername, sizeof(sendername));
			new length = strlen(cmdtext);
			while ((idx < length) && (cmdtext[idx] <= ' '))
			{
				idx++;
			}
			new offset = idx;
			new result[64];
			while ((idx < length) && ((idx - offset) < (sizeof(result) - 1)))
			{
				result[idx - offset] = cmdtext[idx];
				idx++;
			}
			result[idx - offset] = EOS;
			if(!strlen(result))
			{
				SendClientMessage(playerid, COLOR_GRAD2, "» Scrie: (/l)ocal [local chat]");
				return 1;
			}
  	        if(PlayerInfo[playerid][pHMuted] == 1)
			{
				SendClientMessage(playerid, TEAM_CYAN_COLOR, "[UltraGaming RPG]: Ai mute, nu poti utiliza aceasta comanda.");
				return 1;
			}
			format(string, sizeof(string), "» %s: %s", sendername, result);
			ProxDetector(20.0, playerid, string,COLOR_FADE1,COLOR_FADE2,COLOR_FADE3,COLOR_FADE4,COLOR_FADE5);
			printf("%s", string);
		}
		return 1;
	}

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
  • Similar Content

    • By FlobertRO
      Buna , am si eu o problema . Mi-se restarteaza serverulul random . In server_log am gasit asta : 
      Stie cineva ce pot face  Va rog ❤️ . Multumesc frumos
       
       
      [23:17:26] [join] rezana has joined the server (1:---------------------) [23:17:26] [debug] Run time error 4: "Array index out of bounds" [23:17:26] [debug] Accessing element at index 1 past array upper bound 0 [23:17:26] [debug] AMX backtrace: [23:17:26] [debug] #0 00200b24 in ?? (... <1 argument>) at GM.pwn:8108 [23:17:26] [debug] #1 000aef80 in public MP_OPC (playerid=1) at C:\Users\xda\Desktop\gamemode-impact\gamemode-rpg-impact\pawno\include\YSI\y_hooks/impl.inc:633 [23:17:26] [debug] #2 native CallLocalFunction () from samp03svr [23:17:26] [debug] #3 0000c77c in public SSCANF_OnPlayerConnect (playerid=1) at C:\Users\xda\Desktop\gamemode-impact\gamemode-rpg-impact\pawno\include\mSelection.inc:432 [23:17:26] [debug] #4 00003210 in public Itter_OnPlayerConnect (playerid=1) at C:\Users\xda\Desktop\gamemode-impact\gamemode-rpg-impact\pawno\include\sscanf2.inc:236 [23:17:26] [debug] #5 00001684 in public OnPlayerConnect (playerid=1) at C:\Users\Florin\Dxda\gamemode-impact\gamemode-rpg-impact\pawno\include\YSI\y_iterate.inc:646
    • By .Zedd
      Salut, am luat un server de pe ultra host, am urcat game mode ul corect, un game mode editat de david tuts, pornesc serverul si cand dau login se opreste serverul.. care ar putea fi problema? Multumesc anticipat.
    • By Raul112233
      Salut,am si eu o problema!!
      Cand ma fac duty in lspd si pun tinta imi da server closed connection!!
      De ce??
       

    • By TheGodfather
      Salut, cand incerc sa deschid un server ca sa fac un text td, dupa cateva secunde se opreste. Pe langa asta nu imi apare niciun buton, sa adaug text sau ceva. Am folosit tutorialul lui edison, in logurile serverului nu apar erori.
       
    • By Ema Stone
      Salutare! Sa va explic problema mea, mi-am cumparat host, mi-am editat cat de cat un gamemode, l-am testat in localhost cu inca un prieten, apoi l-am bagat pe host, am pus parola si l-am testat si acolo online. Toate bune si frumoase pana ce i-am scos parola, acum dupa ce i-am scos parola si oricine poate sa intre am dat de problema care mi-a pus capac. 
      Oricine poate face cont si juca pe serverul meu, numai eu nu pot!! Am reinstalat samp, am dat restart la server de 15 mii de ori.. nimic! Ceilalti pot juca fara probleme dar mie imi da "Serverul nu rapunde". O fi de la antivirus, de la ip-ul meu.. habar n-am.  Am facut si alte conturi, tot la fel..
      Pe alte servere de samp imi merge perfect. ex: bugged, b-hood etc. Doar la serverul meu nu vrea sa se conecteze. Putin ajutor va rog, daca stie cineva!
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more details you can also review our Terms of Use and Privacy Policy.